Tag Archive for 'iPhone 4'

Semi-tethered jailbreak for iOS 5

iOS 5 has already been jailbroken to allow running on unofficial 3rd party apps, but the current jailbreak with Redsn0w is considered a “tethered” jailbreak because it requires that the phone be tethered and re-jailbroken any time your jailbroken iPhone, iPad or iTouch is rebooted.

We still await someone clever enough to create a fully untethered jailbreak of iOS 5, but in the meantime, there is “Semi-Tether” a semi-tethered jailbreak available from Cydia, one of the premier app stores for jailbroken devices.  Unfortunately, some apps won’t work after a reboot, but at least most of them well. For more info, check out App Advice’s article on SemiTether.

Tethered Jailbreak for iOS 5 on iPhone 4, 3gs, iPad and iTouch with RedSn0w

Those amazing iOS hackers have done it again!  iOS 5 has only been out a few weeks, but there is already a tethered jailbreak for all but the very latest hardware supported by iOS 5.  That’s right, your iPhone 3gs, iPhone 4, iPad, and recent models of the iPod Touch can run a jailbroken iOS 5.  I expect soon we’ll see the iPhone 4s supported too.  What’s more, there are already a jailbreak for the still-in-beta iOS 5.0.1.

If you are ready to dive in yourself, it’s best to go to the source and download the Windows or Mac versions of redsn0w 0.9.9b7.

If you’d like an overview of the process, check out these articles:

iOS 5 unlock for iPhone 4 and iPhone 3gs with Ultrasn0w

iOS 5 was jailbroken soon after release. Jailbreaking allows you to run 3rd party apps on your iOS device that haven’t been approved by Apple for distribution through the office iTunes App Store.  Unlocking builds on jailbreaking to remove the carrier lock for your GSM iOS device. For example, US iPhone owners who want to use T-Mobile, rather than AT&T have to used an unlocked phone.

Well, hold on to your seats!  You saw it here first (unless you didn’t)!  iPhone 4 and iPhone 3GS owners can now unlock their phones running iOS 5! For more details, check out this helpful post about UltraSn0w 1.2.4, which makes it all possible.

Be careful though, don’t rush to upgrade to iOS 5 you need to be careful about what version of the baseband code you are running!